UE4 Niagara - Static Mesh Sampling and Vertex Density

I am using the Sample Static Mesh and Static Mesh Location modules to spawn a bunch of particles. However, the density of particles is extremely uneven, with all of the particles clustered into the details on the geometry. I’m sure this is because the particles are spawned based on vertices. (See example gif below)

Ideally, I would like the particles to be evenly distributed across the mesh - so the blade of the sword would have the same amount as the handle, etc.

Hence my question - is there a way to make the particles spawn based on the surface of the geometry as opposed to the verts? Or is there something I can do to make the distribution of particles more even across the static mesh’s surface?

Thanks for any help you can give! :slight_smile:

StaticMeshDensity

you can use UV if unwrapped properly. to kill particles where vertex count is higher.

There is indeed on option for this in the StaticMesh settings. You basically enable it for the StaticMesh globally.
image

On Skeletal Meshes you have the same option with some additional ones like setting up SamplingRegions.

7 Likes