[Solved] Problem with amplify shader, we can see the square of my texture

unity
shaders
ase

#1

Hello,

So my problem is pretty simple, we can see the square of my texture which is a simple dot in photoshop (it’s my debug texture). I created a shader on ASE, a simple shader to choose the texture of the particle editor.

this is the render of the texture in my particle system.

My texture settings (in case the problem comes from it) this is a white dot and a black background :

and the shader I created .
When I change the Blend RGB as Src: Src Color and Dst: One; the problem of the square disapear but it became additive T.T )

I was looking to created a simple alpha blended shader (not additive because I want some dark color).
I’m a newbie to ASE, I use Unity 2019.1.0b (order from my boss).

Thanks for your help ! :slight_smile:


#2

Make both Blend modes Transparent. And use Alpha channel instead of RGBA into opacity


#3

My texture doesn’t containt any alpha, so the result is black :confused: particle2


#4

OMG I find the solution, I just connect channel RGB without the Alpha channel and it works !

It’s been several days I struggle and it was so simple I just want to hit me … Anyway thanks for your help @Disturbed ! :smiley:


#5

glad it worked out, having alpha channels on textures are what i use so i can see why you would have trouble with it. Good work


#6

I used to work with alpha channel too the exception is for this shader haha.