Slate Editor - 1.75 Update & Free for individuals!

staffpicks

#21

Hey @alex.underhill btw: your http://www.facedownfx.com/ doesn’t point to your https://facedownfx.bitblox.me/ which can make it hard to find on google, because the facedownfx.com is the only one that showed up in results for me. :stuck_out_tongue:


#22

I utterly regret using that service. It said I could redirect facedownfx.com to it, but if I do that, it breaks my SSL setup for the actual documentation, downloads etc. Thanks for the heads up, I’d love to get it sorted.


#23

Hi I’m just wondering, I’m still playing with the demo. can I break a flipbook to separate frames? I look in the “Help”(documentation), but no luck.


#24

An existing flipbook back in to frames?


#25

Indeed, possible at all?


#26

Absolutely! It’s one of my favourite features.
Hit up the icon that looks like a hashtag/grid - this is the Devolver.

You can either choose from a tile image that’s already loaded, or manually load from a file path/explorer window.


Then just tell it how many tiles your flipbook is composed of.
The downsample system allows you to specify how big the output image slices are - capped of course to the source cell size as maximum, and any minimum.

Just hit commit and that will be your new Slate with tiles.

All these tiles are then stored on the GPU, so you may need to Export Absolute Tiles or Save All Raw files which will dump them to disk.


#27

Thanks man! Very useful package you made there :slight_smile:


#28

Shit, I’ll get this just for the motion vectors.


#29

Just the optical flow tools alone are super useful! I haven’t touched anything else, but those are pretty valuable for my current research :smiley:


#30

Very useful + flow tools are super.

Thanks!


#31

Sorry for the double post, having a little bug here.

Finished a little flowy flipbook yesterday, opening my savefile up today doesn’t want me to preview the flow.
Flowmap doesn’t get loaded automatically so I generate again… but no flow!
Found out Sample Y Res is jumping back to 256 while Sample X Res stays on 128 once I close the tool.
My tiles are 128 square, by changing Sample Y Res back to 128 and hitting Generate All it flows again nice and square!


#32

Thanks, this seems like something that should be straightforward to fix; I’ll add it to the next build.

Re: not loading flow maps - at the moment it considers flow maps as transitory assets that arent saved as part of the project - under the idea that they are fairly deterministic and a button press will get you exactly what you had before. Obviously right now with that bug that’s not 100% the case - so once that’s fixed it’ll be back to that.

But it does raise a question of whether flow map data should also save with the project - it feels like it maybe should.


#33

Cool thanks for that.

Yeah no need for the flow textures to get loaded I guess, since they are as you say deterministic and just one click away. Only since I saved the file with flow active, my guts kind of expect it to be still around once I reopen… some convenience thing I guess…


#35

How does the optical flow compare to twixtor?


#36

Nice looking editor, Does it run on both Mac and PC?


#37

Thanks! No Mac build right now I’m afraid.


#38

Not too sure - I haven’t tried Twixtor myself so I don’t know exactly how it stacks up - instead I focused on what VFX would need from such a feature. I would imagine we’re doing a very similar system to them as the implementation of this is via OpenCV.

What I do know is that there are additional features cooked in specifically for RTVFX/Our applications of it. Slate computes the elusive “magic number” for shader displacement weights [with a super advanced Copy to clipboard to boot!] & can tell you the maximum possible magnitude so you can make sure you’re getting the most out of your flow textures.
There’s also a real-time playback viewer of this effect in the Anim Previewer.

There’s a couple more additions I’m adding to it within the next build to make it completely customizable - pretty excited about those.

I’d recommend trying the demo if you’re not sure, it’s all available & working there.


#39

I gotta say, it’s looking pretty badass! Maybe you can add a neural net stylizer to your filter list. :smiley:


#40

In pasting into the key field, i had a space on the end. So it told me the key was invalid. You might want to make it ignore spaces.
:slight_smile:


#41

Should be getting two copies at work in the near future, thanks again @alex.underhill! I’m excited to start using this