Render a Scene on Unity - Lightmapping Setting - Baking

Hello everyone ! *** UNITY NOOB HERE ***

I am sorry, I’m feeling like posting everytime :x but I searched on Google during like 10 hours and I don’t understand so I hope to find an Unity expert here to answer my questions.

I finished my Lighting scene, and now I want to have a nice render in the Game view (to animate a camera and do a cinematic). I tried a lot of setttings, waited longs hours… But I’m still not convinced. My Scene view is more beautiful than the Game view which looks pixelized…


You’ll find attached my lighting setting.

My questions are:

  • What can I do to have a nicer render?
  • In Unity 2019, is “Generate Lighting” like Baking?
  • Is there something I can do not to have to generate the lighting everytime I open the scene ? (Is it possible to open my final scene with the lighting already baked ?)

Thank you! I’ll never be able to thank this community enough for all the help and support and I hope to be able to give back to it one day.

Hey @Mowrose,

1: A few things to try:

  • Increase the ‘Lightmap Resolution’ texels value, you only have a single lightmap at the moment, for a cinematic render I wouldn’t worry about having more. You can use the ‘Lightmap Scale’ value to tweak the texel values per object and balance things out where needed.
  • I find the ‘Progressive GPU’ faster than ‘Progressive CPU’ for baking. Mileage may vary depending on your hardware.
  • Check your quality settings / post processing profile to see if you can increase anti-aliasing or other settings to improve what you see in the game view
  • Rather than use the scaling 16:9 game view ( top left drop downs in the game view panel ), set an actual resolution here ( as high as you need ), if you’re using the Unity Recorder package to output the final video, it will output at that resolution rather whatever it’s being dynamically scaled to in the game view.

2: Generate Lighting is baking
3: The lightbake should save as long as you’re saving the scene once it’s finished. I’ve never had a problem where it doesn’t save, so I cant offer much advice here… You could try copying everything into a new scene and see if that helps.

Hope some of that helps you out :+1:

1 Like

Yeah ! Thank you for your help. It was very hard for me to understand why so I asked an Unity employee and he helped me haha ! Forgot to put the topic in resolved. Thank you for your time. :smiley:

you can also create your own lightbake parameters where you select from the drop down “default -highresolution” option:

Documentation here:
https://docs.unity3d.com/560/Documentation/Manual/LightmapParameters.html

  1. Upping your irradiance budget and quality will improve resolution
  2. Increasing Pushoff (lightly) will help remove unwated shadowing and noise

Scene looks great by the way!

No problem, glad you got things sorted! :slight_smile: