Problem emissives lights after reopening my scene - UNITY


I’m learning the lights in Unity. I did that:

Saved my scene, my project, my prefabs before closing unity.

Then when I opened it again, my emissives lights looks like that:

Do you have any idea why ? I want to correct that to have the same thing than before.

Thanks !!

(I didn’t touch anything and the lights is in auto generate mode.)

Might be that you are not previewing lights on the scene? Click on the lightbulb icon located in the toolbar on top of your Scene window. Should be next to a “2D” button and such.

Hannn I found the problem: the next step was to put a FPS Controller in my scene: A first person character.
When I disable the FPS Controller and active the SciFiCamera it works. So it looks like my lights don’t work with the FPS Camera. So I have to find how activate the post processing in my FPS view.

Should be easy! Add a Post Process Layer component to your FPS Camera. Then set the Layer to “Postprocessing”, and also set it on the top right corner of the inspector window. Then, add a Post Process Volume component, and set “is global” to true. Select your desired Postprocessing Profile, and it should be working!


You are amazing. It works. Thanks a lot for your help !!! :smiley: I’m so happy haha

1 Like