Prevent Niagara system to go through Walls

Hey, I’m new here


I made smoke effect inside unreal engine 4.27 and this smoke goes though walls. I want to avoid this and is there any way to do so?
I tried to fix using collision but not good result since my emitters are scaled up

U can make a gradient in the material with Depth Fade(you can multiply it with the opacity of the texture)

Never scale emitters. It always breaks.
There are no cheap ways of doing it. Either rely on collisions or make a worldspace mask that hides or collapses the particles.

1 Like

Not a simple solution, but: https://twitter.com/vuthric/status/1295773219186606081

1 Like

Also from Ryan DowlingSoka, shared on Asher Zhu’s discord:

I’ve also done a version of this to save texture space, and not use the more hacky (read: less officially supported) parameter collection setup we used on tactics:

I convert the world coordinates of the particle into radial coordinates, and use the angle as a u lookup into a strip texture storing all the ray lengths. I then reconstruct the mask the same way that Giuseppe did on tactics.

By putting it in a texture then you can also composite on rays over multiple frames.

You can also change the sharpness of your mask by adding more texture resolution in the x axis, thereby adding more angles you sample at, and because you are texture sampling you can filter the adjacent angles pretty easily/cheaply.

It means you can do like a 256x1 texture for each system.

1 Like

I was looking for this for about 15min and just couldn’t find it :smiley: Thank you for easing my suffering…